NBN Upstream Outage

Incident Report for aera

Resolved

This incident has been resolved.
Posted May 25, 2026 - 14:43 AEST

Identified

We are currently investigating the root cause of this issue.

Performance will return momentarily.
Posted May 25, 2026 - 11:32 AEST
This incident affected: Internet.